Laravel5.2基于laravelcollective/html使用Form和HTML

2016-03-03 17:06:13 |  分类:PHP

    illuminate/html 作为从 4.* 版本中分支出来的对于 html 和 form 便捷写法的类库,已经在 5.0.* 中收到了兼容. 但是 illuminate/html 只支持 laravel 5.0.* 的版本. 这让升级到 5.0以上的的开发者头疼不已.

    然而我们还有另一个解决方案,就是使用laravelcollective/html。
 
 
 

编辑 composer.json 请求laravelcollective/html类库.

"require": {
    "laravelcollective/html": "5.2.*"
}

接下来,执行composer更新操作:

composer update

接着,在 config/app.php文件里的providers数组中,添加如下代码:

'providers'=>[ // ...
Collective\Html\HtmlServiceProvider::class, // ...
],

最后,在 config/app.php文件里的aliases数组中,添加Form和HTML别名:

'aliases'=>[ // ...
'Form'=>Collective\Html\FormFacade::class,'Html'=>Collective\Html\HtmlFacade::class, // ...
],
更多关于laravelcollective/html的使用方法请参考官方文档
 
 
2016-03-03 17:06:13 |  阅读( 0 ) |  评论( 0)
分享到: